Go Back   Desktop & Server Management (DSM) Forum > GERMAN > enteo v6 > enteo v6 Patch Management
Register FAQ Members List Calendar Search Today's Posts Mark Forums Read

 
 
Thread Tools Search this Thread Display Modes
  #1  
Old January 11th, 2011, 07:09
alex.heim alex.heim is offline
Neuer Benutzer
 
Join Date: 03-30-07
Posts: 3
Default v6.2 - Reboot-Steuerung MS Patches

Hallo zusammen,

ich möchte hier in einer EnteoV6 Umgebung eine Installations-Steuerung für die Client-Installationen aufbauen. Bei einer Neuinstallation eines Clients soll dabei alles via AutoInstaller laufen. Zusätzlich werden auch die MS-Patches via Enteo verteilt. Wir verwenden dabei den aktuellen Patch-Level 7 (mit den Patch Management Execution Packages). Die Patches sollen während der Neuinstallation ebenfalls via AutoInstaller ausgeführt werden, einmal nach der OS-Installation und ein letztes Mal am Ende der Installation. In den Infrastruktur-Einstellungen hab ich das PM so konfiguriert, dass es vor den Applikationen laufen soll. Bei Neustart-Anforderungen durch das PM ist "Benutzer entscheidet" eingestellt, was im laufenden Betrieb ja Sinn macht. Bei einer Neuinstallation des Clients hingegen möchte ich aber erreichen, dass der Client automatisch bootet. Eine separate Staging-Site mit anderen PM-Reboot-Einstellungen scheidet aus, da wir die Clients auch dezentral an ihrem Arbeitsplatz re-installieren möchten.

In der Befehlsreferenz (Hilfe) ist irgendwo die Rede von zwei Befehlen "SetUnattendMode" und "LeaveUnattendMode". Laut Doku ist das genau für den Fall gedacht, den ich hier anwenden möchte. In der Praxis gibt es allerdings nur den Befehl "LeaveUnattendMode", was mir an der Stelle dann leider auch nicht weiterhilft.

Auch meine Hoffnung, dass der Enteo Installer den UnattendMode automatisch am Flag "InstallInProgress" erkennt, scheinen sich nicht zu erfüllen. Jedenfalls hat er beim Test trotzdem vor dem Reboot nachgefragt.

Hat irgend jemand von euch hierfür eine Lösung (mal abgesehen davon, dass der Client-Installationsvorgang komplett ohne Autologin via Service-Installer ausgeführt wird)?

Vielen Dank für eure Vorschläge!

Gruss
Alex
  #2  
Old January 11th, 2011, 07:49
Frank Scholer's Avatar
Frank Scholer Frank Scholer is offline
Erfahrener Benutzer
 
Join Date: 04-24-04
Location: Pforzheim
Posts: 1,920
Default

Hallo Alex,

es ist tatsächlich wohl so, dass es den Befehl "SetUnattendedMode" nicht mehr gibt. War mir noch garnicht aufgefallen...

Der hat allerdings nichts anderes gemacht, als unter "HKEY_LOCAL_MACHINE\SOFTWARE\NetSupport\NetInstall " einen DWord-Value anzulegen namens "UnattendedMode" und diesen auf 1 zu setzen. Das lässt sich also auch manuell sehr leicht implementieren. Allerdings wird es wohl seinen Grund haben, warum der Befehl rausgenommen wurde - nämlich ziemlich sicher, weil er nicht mehr das tut, was er vorgibt tun zu wollen ;-)

Zu deinem Problem:
Quote:
Eine separate Staging-Site mit anderen PM-Reboot-Einstellungen scheidet aus, da wir die Clients auch dezentral an ihrem Arbeitsplatz re-installieren möchten.
Würde ich jetzt nicht so sehen - du könntest einfach für jede Site eine zweite mit identischer Site-Definition anlegen. Nur dass eben für die Produktion noch ein Kriterium wie "InstallInProgress = 0" und für das Staging "InstallInProgress = 1" reinkommt (wobei InstallInProgress dann natürlich eine benutzerdefinierte Variable aus Registry wäre). Oder eben ein anderes Merkmal, woran der NI-Client erkennt, dass ne Grundbetankung läuft oder nicht...

Kannst's ja erstmal mit dem Reg-Key probieren (ist sicher weniger aufwändig).

HTH, Grüße Frank
  #3  
Old January 14th, 2011, 09:15
m.michalski's Avatar
m.michalski m.michalski is offline
Erfahrener Benutzer
 
Join Date: 11-02-06
Location: Frankfurt/Main
Posts: 205
Default

Moin,

seit dem Patch 7 ist in der "InstallProgress.reg" des "Default PostOS Action Package" ein neuer Wert "OSInstallInProgress" hinzugekommen, an dem sich das PM orientiert.

Gruß, Markus
  #4  
Old January 31st, 2011, 16:08
alex.heim alex.heim is offline
Neuer Benutzer
 
Join Date: 03-30-07
Posts: 3
Default

Hallo Frank,

vielen Dank für deine Antworten zu diesem Thema. Ich hab es inzwischen über die zweite Variante (mit einem Registry-Flag) gelöst. Wollte es eigentlich mit dem InstallationInProgress Key machen, aber ich hatte bei den Tests festgestellt, dass der Key auch beispielsweise im Betriebsmodus dann temporär gesetzt wird, wenn das Patchmanangement aktiv wird und Patches installiert (evtl. in Verbindung mit irgendwelchen Reboot-Anforderungen vom Patchmanagement).

Wie auch immer, jetzt funktioniert es.

Gruss
Alex
  #5  
Old July 4th, 2012, 15:59
Maxl Maxl is offline
Benutzer
 
Join Date: 08-20-09
Posts: 55
Default

Wir bereiten gerade die Migration von der V5.86 auf die DSM7 vor gibt's da wirklich keine bessere Möglichkeit als 2 Sites anzulegen?
Damit entsteht im Anlegen der Sites in der neuen Umgebung der doppelte Aufwand.
 


Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

vB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump

   

All times are GMT +1. The time now is 21:49.

Powered by vBulletin Version 3.6.7
Copyright ©2000 - 2017, Jelsoft Enterprises Ltd.