Go Back   Desktop & Server Management (DSM) Forum > GERMAN > DSM 7 > DSM 7 OS Deployment
Register FAQ Members List Calendar Search Today's Posts Mark Forums Read

Reply
 
Thread Tools Search this Thread Display Modes
  #1  
Old January 27th, 2014, 07:06
schurl85 schurl85 is offline
Benutzer
 
Join Date: 10-02-06
Posts: 75
Default UEFI Boot

Ciao,

habe ein kleines Problem mit dem UEFI Boot. Hab hier ein Dell Venue 11 Pro Tablet. Leider hat das im Legacy Modus keinen PXE boot, nur per UEFI. Jetzt hab ich mit mal 7.2.1 HF6 Notes durchgelesen und die von 7.2.2 (aktuelle Umgebung). Leider bringt mich beides nicht weiter.
Habe den Reg Key aus 7.2.1 HF6 gesetzt, da er nicht vorhanden war. Habe auch das Boot Environment 2x neu gemacht. Bekomme aber leider im im PXE immer den Fehler " OSD Proxy needs additional time" und wenn die abgelaufen ist "PXE-E99: Unexpected network error".
In den Logs hab ich nichts dazu gefunden. Server und Client sind im gleichen Netz.

Code:
08:02.49.775  : --------------------------------------------------------------------------------
08:02.49.775  : LogFile C:\Program Files\Common Files\enteo\NiLogs\OSD\osdpxemxPool_0000000448.log, started 27.01.2014 08:02.49
08:02.49.775  : Application : C:\Program Files\NetInst\mgmtagnt.exe(PID: 3336 [5332])
08:02.49.775  : Version : 7.2.2.2331 
08:02.49.775  : --------------------------------------------------------------------------------
08:02.49.775  2 osdPxeMx.dll  Value of Option 93: 0x00 0x07.
08:02.49.775  0 osdPxeMx.dll  PXE Client D4C9EFF7B8C1 requested bootmenu
08:02.49.775  0 osdPxeMx.dll  Redirect client to Port 4011.
08:02.49.775  0 osdPxeMx.dll  Sending reply to 10.152.22.35:67
08:02.49.775  : End Of Logfile
Code:
08:02.53.384  : --------------------------------------------------------------------------------
08:02.53.384  : LogFile C:\Program Files\Common Files\enteo\NiLogs\OSD\osdpxemxPool_0000000450.log, started 27.01.2014 08:02.53
08:02.53.384  : Application : C:\Program Files\NetInst\mgmtagnt.exe(PID: 3336 [3956])
08:02.53.384  : Version : 7.2.2.2331 
08:02.53.384  : --------------------------------------------------------------------------------
08:02.53.384  2 osdPxeMx.dll  Value of Option 93: 0x00 0x07.
08:02.53.384  0 osdPxeMx.dll  PXE Client D4C9EFF7B8C1 requested bootmenu
08:02.53.416  1 osdPxeMx.dll  Got boot configuration for Client '30964'.
08:02.53.416  0 osdPxeMx.dll  Boot server type: 0xFFF1
08:02.53.416  0 osdPxeMx.dll  Adding boot menu to reply.
08:02.53.416  0 osdPxeMx.dll  Sending reply to 10.152.22.39:4011
08:02.53.416  : End Of Logfile
mfg
__________________
MfG
Georg Leitner
Reply With Quote
  #2  
Old January 27th, 2014, 09:49
Mel Mel is offline
Erfahrener Benutzer
 
Join Date: 09-15-09
Posts: 1,873
Default

Ich hab hier ein Dell Latitude 10, das hat den gleichen Fehler.
Das ist ein Bug in der UEFI PXE Implementierung, die Dell verwendet, wodurch da das PXE Bootemnü nicht funktioniert - den Bug hat mir der Dell Support auch bestätigt (nachdem man mich einige Wochen versucht hat mich mit Ausreden abzuspeisen) nur scheint die motivation ihn zu fixen leider eher gering zu sein (nur ein Kunde - who cares ?)

Also wende dich doch bitte an den Dell Support, daß die endlich ihren PXE Boot fixen sollen, dann sind wir schon zwei
(und danach an den Frontrange Support wegen einem Workaround)
Reply With Quote
  #3  
Old January 27th, 2014, 10:01
schurl85 schurl85 is offline
Benutzer
 
Join Date: 10-02-06
Posts: 75
Default

hmmm, also obs wirklich an einem pxe bug liegt? habs auch bei einem hp 810 g1 und 840 g1 probiert. kommt aufs gleiche raus bei mir.

das heißt für mich aber, dass ich die tablets/notebooks mit einem stick installieren muss. ist auch gerade nicht die feinste variante.

trotzdem danke für deine info!
__________________
MfG
Georg Leitner
Reply With Quote
  #4  
Old January 27th, 2014, 10:11
Mel Mel is offline
Erfahrener Benutzer
 
Join Date: 09-15-09
Posts: 1,873
Default

definitiv ein pxe bug - zumindest bei meiner version hier auch sehr schön: option 43 (mit bootmenü) am dhcp server eintragen und das tablet gibt beim netzwerkboot erstmal ein paar zeilen datenmüll aus und versucht vom tftp dienst ne datei abzufragen, deren name sehr zufällig aussieht.

ich vermute, daß die pxe implementierung zugekauft ist, denn bei einem siemens hab ich das auch schon gesehen.
andere haben's richtig hinbekommen.
und ganz komisch ist vmware: da funktioniert's, aber das bootmenü wird nicht angezeigt...

aber wie gesagt: frag beim frontrange support nach dem workaround.
Reply With Quote
  #5  
Old January 27th, 2014, 10:36
schurl85 schurl85 is offline
Benutzer
 
Join Date: 10-02-06
Posts: 75
Default

ok danke nochmals, werd mich mit frontrange in verbindung setzen. habs auch nochmals in VMWare probiert, dort funktioniert das ohne Probleme.

lg
__________________
MfG
Georg Leitner
Reply With Quote
  #6  
Old January 28th, 2014, 15:26
NicoS's Avatar
NicoS NicoS is offline
Erfahrener Benutzer
 
Join Date: 09-10-07
Location: Bad Rappenau
Posts: 1,339
Send a message via ICQ to NicoS
Default

Hallo,

Ich habe derzeit auch UEFI-PXE Probleme mit einem Gerät, welches keinerlei Legacy mehr Unterstützung bietet. Leider sind es auch noch Evaluation Geräte die es nicht am Markt gibt, dementsprechend auch keinerlei Support.

Es handelt sich um Tablets mit einem Intel Atom, der nur 32 Bit unterstützt. Nachdem alles mögliche fehlgeschlagen ist, habe ich folgenden Workaround:

- In DSM ein aktuelles Boot Enviroment mit allen notwendigen Treibern erstellen.
- Lokales BootEnviroment mit Windows ADK erstellen. (Copype bla bla bla)
- Mit MakeWinPEMedia /UFD einen Boot Stick versorgen (funktion in Windows ADK)
- Das DSM Boot Enviroment (winpe40.wim) nehmen und zu "boot.wim" umbenennen.
- Die Boot.wim auf dem USB Stick gegen die boot.wim aus DSM austauschen.

voilà... UEFI Bootfähiger USB Stick mit DSM Bootenviroment.

Das löst leider (noch) nicht das PXE Problem, aber ist ein Workaround um Problemgeräte zumindest mal inital zu versorgen.
__________________
- Nico Schmidtbauer
Fujitsu TDS GmbH
Privater Blog - Generelle IT & Deployment Themen, DSM Themen und DSM Automatisierung via PowerShell
Reply With Quote
  #7  
Old January 28th, 2014, 15:34
Frank Scholer's Avatar
Frank Scholer Frank Scholer is offline
Erfahrener Benutzer
 
Join Date: 04-24-04
Location: Pforzheim
Posts: 1,897
Default

Hallo Nico,

sorry, aber das kapier ich nicht: nach allem, was ich bisher über UEFI-basierte Geräte gelesen habe, haben die entweder ein CSM (Compatibility Support Module) und sind dann BIOS-Kompatibel - dann kann man darauf auch ein 32-Bit OS installieren. Oder sie haben eben keinen Legacy Mode, dann kann man doch nur ein 64-Bit OS draufpacken...

Oder hat sich da mittlerweile was geändert?

Grüße Frank
__________________
Frank Scholer | NWC Services GmbH
www.nwc-services.de/de/service-de/blog
Reply With Quote
  #8  
Old January 28th, 2014, 16:42
NicoS's Avatar
NicoS NicoS is offline
Erfahrener Benutzer
 
Join Date: 09-10-07
Location: Bad Rappenau
Posts: 1,339
Send a message via ICQ to NicoS
Default

Hallo Frank,

Sowohl das Tablet vom OP als auch mein Tablet hier basieren alle auf Intels Bay Trail mit eimem Atom Z3770er drin. 64-Bit ist von der CPU Architektur her zwar grundsätzlich unterstützt aber trotzdem beim kompletten SOC nur auf 32-Bit beschränkt. Ich glaube erst Q1 diesen Jahres wird Bay Trail auch 64 Bit-OS tauglich.

Du bekommst auf den Tablets definitiv kein 64 Bit BootEnviroment oder OS zum booten. Ebenso haben Bay Trail basierende Geräte keinen Legacy Modus mehr, auch Zugang zu einer EFI shell gibts wohl nicht... ich hab keine Ahnung was Intel da gebaut hat... aber uns Softwareverteilern macht es das leben schwer.

Das einzige was ich auf meinem Gerät zum Booten bewegen konnte:
- Windows 8.0 32 Bit DVD
- Windows 8.1 32 Bit DVD
- Mit Windows ADK erstellter USB Stick mit 32 Bit Boot Enviroment

Ich bekomme mein Gerät an DSM2013.2 mittlerweile so weit, dass er anfängt das WinPE runterzuladen, aber dann mit TFTP Aborted abbricht (anderer Thread glaube ich). Da meine Geräte leider non-supported sind, kann ich leider auch nicht auf den Support zurückgreifen und wegen EFI Implementation nachbohren

Deshalb der Workaround mit dem USB Stick.
__________________
- Nico Schmidtbauer
Fujitsu TDS GmbH
Privater Blog - Generelle IT & Deployment Themen, DSM Themen und DSM Automatisierung via PowerShell

Last edited by NicoS : January 28th, 2014 at 16:54.
Reply With Quote
  #9  
Old January 28th, 2014, 17:18
Mel Mel is offline
Erfahrener Benutzer
 
Join Date: 09-15-09
Posts: 1,873
Default

@Frank: im unterschied zur PC-kompatiblen architektur gibt es verschiedene UEFI architekturen
UEFI 32
UEFI 64
können anscheinend nur bootloader für die architektur laden - und damit ist man bei der windows plattform entsprechend eingeschränkt.

eigentlich spricht aber nichts dagegen, daß ein 64 bit prozessor mit einer 32 bit uefi firmware kombiniert wird.

und die 32bit atom tablets kommen natürlich nur als 32 bit.

...theoretisch gibts auch noch UEFI BC (Bytecode) was plattformunabhängigen code emöglichen müßte - das ist mir aber noch nicht begegnet

@NicoS: wo hast du das "TFTP aborted" her ? aus dem tftp service logfile oder vom bildschirm des clients ?
Reply With Quote
  #10  
Old January 28th, 2014, 17:27
NicoS's Avatar
NicoS NicoS is offline
Erfahrener Benutzer
 
Join Date: 09-10-07
Location: Bad Rappenau
Posts: 1,339
Send a message via ICQ to NicoS
Default

Quote:
Originally Posted by Mel View Post
@NicoS: wo hast du das "TFTP aborted" her ? aus dem tftp service logfile oder vom bildschirm des clients ?
Aus dem Log. Der Client zeigt nur Downloading NBP File für ca. 5 Sekunden, dann kommt eine Meldung, leider so schnell, dass ich sie nicht lesen kann und dann nur noch ein Schwarzer Bildschirm mit NICHT blinkendem Cursor.

18:23.17.973 0 osdTftpMx.dll UpdateTransactionStatus: transaction \Boot\efi.bcd - new status 2
18:23.17.973 0 osdTftpMx.dll OpenTransaction (0): \Boot\efi.bcd available, file available.
18:23.17.973 1 osdTftpMx.dll Request contains TFTP options.
18:23.17.973 1 osdTftpMx.dll send OACK to x.x.x.x/9176. Size: 12, content: tsize
12288

18:23.17.973 1 osdTftpMx.dll Error message - 0: TFTP Aborted.
18:23.17.973 0 osdTftpMx.dll CloseTransaction (0): (master-)client x.x.x.x/9176 - reason 1.

Edit: Hab den Prozess mal auf Video aufgenommen und das Frame mit der Meldung gefunden "Succeed to download NBP File". Danach dann hängt das System.

Edit2: Hab mir meinen Post nochmal selbst durchgelesen. Request contains TFTP Options hat mir einen wichtigen Hinweis geliefert. Nach ein bisschen recherche... da mein Client Netz und der OSD Proxy nicht im selben Netz stehen, hab ich mal die PXE Optionen 66 und 67 gesetzt. Und siehe da... ich komme weiter! Bis zum blauen hintergrundbild... dann geht das System aus. Mal noch weiter Logs durchsuchen... aber heute nicht mehr.
__________________
- Nico Schmidtbauer
Fujitsu TDS GmbH
Privater Blog - Generelle IT & Deployment Themen, DSM Themen und DSM Automatisierung via PowerShell

Last edited by NicoS : January 28th, 2014 at 18:49.
Reply With Quote
Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

vB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump

   

All times are GMT +1. The time now is 08:04.

Powered by vBulletin Version 3.6.7
Copyright ©2000 - 2017, Jelsoft Enterprises Ltd.