Go Back   Desktop & Server Management (DSM) Forum > GERMAN > DSM 7 > DSM 7 NetInstall
Register FAQ Members List Calendar Search Today's Posts Mark Forums Read

Reply
 
Thread Tools Search this Thread Display Modes
  #11  
Old July 24th, 2015, 10:44
derniwi derniwi is offline
Erfahrener Benutzer
 
Join Date: 02-15-12
Posts: 1,654
Default

OK, man kann die Pakete ja umbauen.
Danke für's Testen.
Reply With Quote
  #12  
Old August 4th, 2015, 11:51
Andree's Avatar
Andree Andree is offline
Benutzer
 
Join Date: 12-02-10
Location: Celle
Posts: 67
Default

Danke für die Rückmeldungen. Mit dem Neustart hatte ich in der Zwischenzeit auch gemerkt. Mhh.... ist noch ausbaufähig das ganze :-)
__________________
Bis dann

Andree
-----------------------
seit 01.01.2014 leider ohne DSM unterwegs ... aber man arbeitet dran es wieder zu bekommen
Reply With Quote
  #13  
Old August 6th, 2015, 12:14
Rene Scheruebl's Avatar
Rene Scheruebl Rene Scheruebl is offline
Erfahrener Benutzer
 
Join Date: 07-07-09
Location: Graz
Posts: 111
Send a message via Skype™ to Rene Scheruebl
Idee

Ich würde einfach während der Installation Maus und Tastatur sperren. Klappt wunderbar. ;-)
__________________
Alles wird gut.
Reply With Quote
  #14  
Old August 12th, 2015, 14:03
bretzeli's Avatar
bretzeli bretzeli is offline
Erfahrener Benutzer
 
Join Date: 04-23-08
Location: Switzerland, Basel
Posts: 461
Default

User Nicht angemeldet > Alle Adobe und Explorer.exe abchiessen, Silent installieren
User angemeldet > Anfrage mit MSGBOX.exe von Scholler und dann alles schliessen und installieren.
Falls user nicht antwortet wiederkommen in 1H und nochmals fragen.
Dann noch Anfragen ob desktop Locked/Screensaver usw.

Mal ein paar Ideen wie komplex es dann werden könnte....


Quote:
Originally Posted by gl-hl View Post
Hallo,

wie geht ihr z.B. beim Update vom Adobe Reader XI MUI vor.

Mein Szenario:
1. Prüfen ob Adobe Reader selbst (AcroRd32.exe) und der Internet Explorer (iexplore.exe) laufen.
2. Danach erscheint eine MsgBox beim Anwender mit einem Countdown zum Beenden.
3. Erst danach erfolgt die eigentliche Installation bzw. das Update

Mein Problem:
Nun öffnen ziemlich viele Anwender direkt nach dem Beenden aus der MessageBox wieder den Internet Explorer, was mir im Anschluss die Policy zerhaut und der Adobe Reader nicht sauber installiert ist.
Eine Reparatur bzw. eine Neuinstallation der Policy ist im Anschluss möglich, jedoch möchte ich dies gerne vermeiden

Gibt es die Möglichkeit div. Prozesse temporär zu sperren?
Oder am besten mit dem Befehl ShowBlueScreen arbeiten?

Wie handhabt ihr solche Themen?

Beste Grüße
G.L.
Reply With Quote
  #15  
Old August 12th, 2015, 14:05
bretzeli's Avatar
bretzeli bretzeli is offline
Erfahrener Benutzer
 
Join Date: 04-23-08
Location: Switzerland, Basel
Posts: 461
Default

Alles wird gut kann man dann in dem Fall nicht sagen. Andere Deployment haben diese option fix eingbaut mit Haken. Bis dann mal ein Paket nicht mehr so lief wie es sollte und alle Keyboard und Mouse waren gelockt.

Das würde ich zweimail überlegen,.....;-)

Quote:
Originally Posted by Rene Scheruebl View Post
Ich würde einfach während der Installation Maus und Tastatur sperren. Klappt wunderbar. ;-)
Reply With Quote
  #16  
Old August 12th, 2015, 15:20
NicoS's Avatar
NicoS NicoS is offline
Erfahrener Benutzer
 
Join Date: 09-10-07
Location: Bad Rappenau
Posts: 1,339
Send a message via ICQ to NicoS
Default

Quote:
Originally Posted by bretzeli View Post
Das würde ich zweimail überlegen,.....;-)
Och wieso? Eine Job Policy ans Ende einer Installationssitzung, die das wieder Frei gibt und gut ist.

Wir haben es ähnlich. Wir vergeben für den "DisallowRun" Reg Key Zahlen von 11 Aufwärts (1-10 haben wir uns für evtl. Einsatz in GPOs reserviert). Die Aufräumarbeiten am Ende der Installationssitzung macht die Jobpolicy und entfernt alle Disllowruns von 11 Aufwärts. Völlig egal ob das Paket schiefgelaufen ist oder funktioniert hat. Nicht das wir alle Browser gesperrt bleiben, nur weil mal im Flash Paket was schief lief
__________________
- Nico Schmidtbauer
Fujitsu TDS GmbH
Privater Blog - Generelle IT & Deployment Themen, DSM Themen und DSM Automatisierung via PowerShell
Reply With Quote
  #17  
Old December 14th, 2015, 15:44
nicor nicor is offline
Benutzer
 
Join Date: 07-23-08
Posts: 39
Default

etwas spät aber bin gerade drüber gestolpert:
ich nehme showbluescreen das reicht in der Regel.

Gruß
Reply With Quote
  #18  
Old December 15th, 2015, 07:47
derniwi derniwi is offline
Erfahrener Benutzer
 
Join Date: 02-15-12
Posts: 1,654
Default

Hallo,

ich habe die Tests für diese Methode beendet. Letztlich aus folgendem Grund:
man muss für jede Software-Installation ermitteln, was nicht gestartet werden bzw. was zum Zeitpunkt der Installation nicht laufen darf. Das ist z.T. recht einfach, bei manchen Anwendungen aber durchaus eine recht große Anzahl an Anwendungen. Diese Liste muss man irgendwo pflegen. Dabei hatte ich aber das Problem mit Lotus Notes / IBM Notes, dass hier während dem normalen Betrieb die "notes2.exe" läuft, diese aber auch während der Installation gestartet wird. Somit darf ich diese nicht blockieren. Sprich, alle Prozesse, die während der Installation angestoßen werden, müssen erlaubt bleiben. Und wenn der Benutzer hier dann doch etwas starten könnte, habe ich durch diese Methode keinen bis wenige Vorteile.

Aktuell ist es so, dass ich einen mittlerweile größeren Job laufen lasse (140 Zeilen inkl. Kommentare), welcher prüft, ob eine oder mehrere vorgegebene Anwendungen laufen und dementsprechend Nachrichten ausgibt. Ein Anwender hat auch die Möglichkeit, Installation für eine begrenzte Anzahl von Tagen aufzuschieben. Und in den eigentlichen Installationspaketen brauche ich zwei zusätzliche Zeilen für die Installation und evtl. zwei für die Deinstallation. Das Ganze kann auch für ein Software-Set verwendet werden, so dass hier nicht pro eScript gefragt wird, sondern nur einmal pro Set.

Bisher läuft es damit gut, ich habe keine wirklichen Probleme gemeldet bekommen und unsere Anwender müssten eigentlich wissen, wenn Sie aufgefordert werden, die Anwendung zu beenden, dies dann auch zu tun bzw. dass in nächster Zeit ein Zwangs-Update ansteht.

Gruß
Nils
Reply With Quote
  #19  
Old April 14th, 2017, 10:12
schurl85 schurl85 is offline
Benutzer
 
Join Date: 10-02-06
Posts: 75
Default

möchte den Thread nochmals aufgreifen.

habe mich jetzt damit umhergespielt und es will einfach nicht so wie ich es will. der disallowrun ist gesetzt und wenn dann im unterordner ein eintrag ist, wird die applikation auch blockiert.

ich habe aber das problem, dass ich dort den eintrag nicht bekomme. folgendes hab ich schon gemacht:

paket ist auf benutzerkontext geflagt, damit der autoinstaller es macht und nicht der service installer.

danach hab ich getestet, wie der befehl geflagt werden muss. hatte es als benutzer, bzw benutzer mit service, hat nicht funktioniert. habe es dann als computer geflagt und wurde beim testen auch beim angemeldeten benutzer und nicht beim service user angelegt. jetzt hab ich das paket freigegeben und es wird wieder nicht beim benutzer in die registry geschrieben.

was mach ich da falsch? würde nur ungern die registry berechtigungen ändern, damit der user selbst den eintrag machen kann.

Georg
__________________
MfG
Georg Leitner

Last edited by schurl85 : April 14th, 2017 at 11:10.
Reply With Quote
  #20  
Old April 20th, 2017, 08:14
schurl85 schurl85 is offline
Benutzer
 
Join Date: 10-02-06
Posts: 75
Default

so habe noch weiter getestet. der Befehl ist jetzt mit Benutzer per Service geflagt. Wenn ich jetzt ein Paket zuweise und dieses dann sofort pushe (Policy Instant sofort ausführen), wirft er mir die Registry Settings mal in den angemeldeten Benutzer, mal in den DSM Local Admin. Sollte eigentlich immer in den Benutzer geschrieben werden. im NPI Log stehen auch die ganzen Variablen inklusive des Benutzers richtig, jedoch nimmt er nicht den Benutzerhive der Registry.
Wenn ich das Paket nicht pushe, wird es korrekt über den AutoInstaller beim nächsten Lauf ausgeführt und der Benutzer bekommt die Registry Settings.

Soll das so sein? Ist das irgendwie ein Bug? Auch wenn ich pushe, sehe ich zuerst die nisrv* logs, da aber angegeben ist im Benutzerkontext wird hier nichts gemacht. Dann erscheint gleich ein niai* log und damit auch das npi log. Wie schon gesagt, im npi log steht auch der angemeldete Benutzer drinnen in den Variablen, aber die Registry settings macht er in den lokalen DSM Admin hinein, was ja falsch ist.
__________________
MfG
Georg Leitner
Reply With Quote
Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

vB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump

   

All times are GMT +1. The time now is 19:40.

Powered by vBulletin Version 3.6.7
Copyright ©2000 - 2017, Jelsoft Enterprises Ltd.