Go Back   Desktop & Server Management (DSM) Forum > GERMAN > DSM 7 > DSM 7 OS Deployment
Register FAQ Members List Calendar Search Today's Posts Mark Forums Read

Reply
 
Thread Tools Search this Thread Display Modes
  #1  
Old March 19th, 2017, 14:16
MichaelAhlswede MichaelAhlswede is offline
Benutzer
 
Join Date: 07-24-08
Posts: 52
Default WinPE40 erkennt M.2 PCIe SSD nicht

DSM Version DSM 7.02.001.2070

M.2 SATA SSD vs M.2 PCIe SSD

In den bisher verwendeten Laptops Dell Latitude E5470 ist eine M.2 SATA SSD eingebaut, Installation Windows 8.1 per DSM problemlos.
Die vor einigen Tagen gelieferten Laptops Dell Latitude E5470 haben eine M.2 PCIe SSD eingebaut.
Windows 8.1 wird mit WinPE40 installiert.
Diese M2 PCIe SSD wird vom WinPE40 nicht erkannt, diskpart findet keine Festplatte.

Wird Windows 8.1 von DVD/USBStick installiert, ist im Gerätemanager unter Speichercontroller ein
"Standard NVM Express-Controller" zu sehen, stornvme.sys,
mit PCI-Ids PCI\VEN_144D&DEV_A804, ...&DEV_A804&CC_010802, ...&DEV_A804&CC_0108

Ich habe diese stornvme.inf mit dism /image:.. /Add-Driver /driver:c:\pfad\... in das winpe40 importiert
musste aber /forceunsigned beim Import verwenden, da ich keine .CAT Datei habe.

WinPE40 erkennt die M2 PCIe SSD noch immer nicht.

Welchen Treiber muss ich in das WinPE importieren, wo findet man einen geeigneten Treiber?
auf www.dell.com/support habe ich bisher nichts passendes gefunden E5470-Win8.1-A03-1889G.CAB

Wie muss ich den Treiber ins WinPE importieren, funktioniert das auch mit
dism /image:... /Add-Driver /driver:..
oder muss ein MassStorageDevice "irgendwie anders" importiert werden ?
Reply With Quote
  #2  
Old March 20th, 2017, 08:49
derniwi derniwi is offline
Erfahrener Benutzer
 
Join Date: 02-15-12
Posts: 1,650
Default

Hallo Michael,

suche hier im Forum mal nach NVMe, da gibt es ein paar Einträge.
Du musst meines Wissens zwei oder drei Patches von Microsoft mit integrieren.

Mangles NVMe-Geräte habe ich selbst aber keine Erfahrung damit.

Gruß
Nils
__________________
Sie haben die Maus bewegt. Bitte starten Sie den Rechner neu, damit die Änderungen wirksam werden.
Reply With Quote
  #3  
Old March 20th, 2017, 19:56
MichaelAhlswede MichaelAhlswede is offline
Benutzer
 
Join Date: 07-24-08
Posts: 52
Default

Die Ursache liegt vieeel weiter zurück, das zur Windows 8.1 Installation verwendete WinPE40.wim basiert auf einem Windows 8.0 (NULL), wurde mit einem Windows ADK 8.0 erstellt.
Es wurde in 2013 erstellt, hat in der Zwischenzeit nur Treiber für Netzwerkkarten Intel I217 und I219 erhalten,
funktioniert prima auch zur Installation von Windows 8.1.

In der Zwischenzeit habe ich ein Windows ADK 8.1 installiert, ein neues WinPE40.wim erstellt.
In der zu Grunde liegenden winpe.wim des ADK 8.1 ist der Microsoft Treiber stornvme.inf/.sys enthalten.
Ein erster Test mit einem per DSM erstellten USB Bootstick zeigte, diskpart findet die M2 PCIe SSD.

Um das Windows ADK 8.1 in der DSM Version 7.02.001.2070 zur Erstellung eines BootEnvironments verwenden zu können,
ist ein kleiner "Trick" notwendig, Registryeintrag ergänzen. Beitrag dazu hier im Forum gefunden

bis zum nächsten Problem
Michael
Reply With Quote
  #4  
Old March 21st, 2017, 11:01
SBR SBR is offline
Erfahrener Benutzer
 
Join Date: 12-03-03
Location: Greifenberg am Ammersee
Posts: 822
Send a message via MSN to SBR
Default

Hallo Michael,

am besten du nimmst gleich das WinPE 10. Damit kannst du auch Windows 8/8.1 installieren.

Einfach nach dem erstellen deines WinPE Bootenvironment die Files im Intern$ austauschen und dein Bootenvironment aktualisieren.

Die neueren Versionen von DSM erkennen auch die neuen ADKs.

Viele Grüße,
Stefan
__________________
Aton Consult
IT-Consulting & Training
Web: http://www.aton-consult.de Blog: http://deployment-guru.blogspot.de/
Reply With Quote
  #5  
Old March 24th, 2017, 09:17
lucky devil lucky devil is offline
Erfahrener Benutzer
 
Join Date: 02-05-08
Posts: 178
Default

Moin,
seit über einem Jahr nutze ich eine "WinPE10 x64" BE-Version auch für "Windows 7 x64", "Server 2012",... OS-Installationen.
Seit ca. August 2016 gibt es WinPE auf BASIS von Windows 10 "1607" (10.0.1.xxx).
Auch diese Version läuft ohne Probleme.
Es wird vermutlich in kürze eine neue ADK-Version "1703" erscheinen.

Viele Grüße
lucky devil
Reply With Quote
Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

vB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump

   

All times are GMT +1. The time now is 17:37.

Powered by vBulletin Version 3.6.7
Copyright ©2000 - 2017, Jelsoft Enterprises Ltd.