Go Back   Desktop & Server Management (DSM) Forum > GERMAN > DSM 7 > DSM 7 OS Deployment
Register FAQ Members List Calendar Search Today's Posts Mark Forums Read

Reply
 
Thread Tools Search this Thread Display Modes
  #1  
Old March 30th, 2017, 13:31
gl-hl gl-hl is offline
Benutzer
 
Join Date: 10-29-12
Posts: 56
Frage Dell Optiplex 5040/5050 - Win10 - UEFI - NVMe SSD

Hallo zusammen,

ich hoffe ihr könnt mir bei folgendem Problem helfen:

Ausgangsxituation:

- DSM 2016.1.3 Patch 3449
- Neue/ältere Dell Optiplex PCs 5040/5050
- Windows 10 Enterprise Build 1607 deDE/enUS
- Treiber in DSM einbinden
- UEFI
- die PCs haben eine M.2 PCIe NVMe SSD

Was bisher funktioniert:
- im Legacy BIOS Modus wird der PC ganz normal und ohne Murren via DSM OSD aufgesetzt, bootet erfolgreich, freigegeben von uns, check, alles gut


Was nicht funktioniert:
Sobald ich bei diesen Systemen auf UEFI umstellen (mit aktiviertem SecureBoot) und versuche das Systeme aufzusetzen funktioniert soweit erstmal alles.
Das Partitionierungs-Skript erkennt die GPT/UEFI Platte, formatiert neu und das Win10 wird erfolgreich installiert.

Sobald die OS-Installation fertig ist und das Win10 versucht das erste mal zu booten, erhalte ich einen BlueScreen mit dem Fehler "INACCESSIBLE BOOT DEVICE"

Ich weiß gerade nicht mehr weiter

Was ich schon gemacht/gechecked habe:
- Neue Bootenvironment erstellt, die Dell WinPE10 Treiber eingebunden (x64 only) und dem Testclient zugewiesen
http://en.community.dell.com/techcen...10-driver-pack
- Den Samsung NVMe Treiber heruntergeladen, extrahiert und in das Bootenvironment injected
- Die Treiber selbst direkt dem Client/der dynamischen Gruppe zugweisen


Hat jemand von euch schon damit zu tun gehabt oder habe ich irgendwo einen BSOD?
Bei uns sind die OptiPlex 5040/5050/7040/7050 im UEFI Modus betroffen (mit einer NVMe SSD).

Vielen Dank und beste Grüße aus Freiburg
Reply With Quote
  #2  
Old March 30th, 2017, 14:02
Mel Mel is offline
Erfahrener Benutzer
 
Join Date: 09-15-09
Posts: 1,924
Default

brauchst du dafür einen treiber für die festplatte ?
falls ja: wird der von osd auf den rechner gebracht ?
imaging oder unattend installation ?
Reply With Quote
  #3  
Old March 31st, 2017, 00:00
NicoS's Avatar
NicoS NicoS is offline
Erfahrener Benutzer
 
Join Date: 09-10-07
Location: Bad Rappenau
Posts: 1,360
Send a message via ICQ to NicoS
Default

Hallo,

da das Boot Environment die SSD sauber erkennt und partitionieren kann, sowie das Windows Setup anläuft würde ich persönlich jetzt den Fehler nicht primär in Richtung WinPE schieben.

Ich könnte mir eher vorstellen, dass es ein Problem mit dem NVMe Treiber Paket gibt, dass dem PC bzw. der dynamischen Gruppe zugewiesen ist.

- Ist es der richtige Treiber?
- Ich hoffe es ist ein echtes PnP Treiberpaket mit INF Dateien und nicht ein "fake"-PNP Paket in dem eine .exe reinpaketiert ist?
- Ist das Treiberpaket richtig geflaggt das es bei OSD verwendet werden darf? / Wird er wirklich angezogen vom Rechner?
(Ggf. im Debug Modus mal booten, und prüfen ob der Treiber auch lokal abliegt unter C:\Drivers)
- Evtl. mal das OEM Setup ausprobieren, wenn sich das über UEFI installieren und booten lässt, dort den / die Treiber abziehen.
- Im allerschlimmsten Fall, den Treiber mal direkt ins WIM injecten

Das wäre so meine Trickkiste / Vorgehensweise.
Gruß
__________________
- Nico Schmidtbauer
Fujitsu TDS GmbH
Privater Blog - Generelle IT & Deployment Themen, DSM Themen und DSM Automatisierung via PowerShell
Reply With Quote
  #4  
Old March 31st, 2017, 08:38
SBR SBR is offline
Erfahrener Benutzer
 
Join Date: 12-03-03
Location: Greifenberg am Ammersee
Posts: 823
Send a message via MSN to SBR
Default

Hallo Freiburger,

welches Partitionsscript verwendest du? Ist auch sicher gestellt das die Partition als GPT Partition angelegt wird?

Ansonsten das Treiberthema anschauen und auf jeden Fall das neuste BIOS der DELL Maschinen verwenden. Da gab es einige Bugfixe für die NVMe Karten.

Viele Grüße,
Stefan
__________________
Aton Consult
IT-Consulting & Training
Web: http://www.aton-consult.de Blog: http://deployment-guru.blogspot.de/
Reply With Quote
  #5  
Old April 4th, 2017, 08:59
gl-hl gl-hl is offline
Benutzer
 
Join Date: 10-29-12
Posts: 56
Default

Hallo Nico,

Quote:
Originally Posted by NicoS View Post
- Ist das Treiberpaket richtig geflaggt das es bei OSD verwendet werden darf? / Wird er wirklich angezogen vom Rechner?
Wo kann ich bei einem PNP-Treiberpaket diesen Flag in der DSMC setzen (sorry für die blöde Fragen...)?

Danke und Gruß
Reply With Quote
  #6  
Old April 4th, 2017, 09:32
NicoS's Avatar
NicoS NicoS is offline
Erfahrener Benutzer
 
Join Date: 09-10-07
Location: Bad Rappenau
Posts: 1,360
Send a message via ICQ to NicoS
Default

(Kein Problem)
Du klickst ein PnP Paket an, gehst in das "Eigenschaften" bzw. "Properties" Tab. Dort gibt es ziemlich am Ende eine Checkbox "Don't use during OS Installation" bzw. "Nicht während Betriebssysteminstallation verwenden" (oder so ähnlich).

Der Haken darf nicht gesetzt sein, wenn der Treiber in der PE Phase runtergeladen werden soll.
__________________
- Nico Schmidtbauer
Fujitsu TDS GmbH
Privater Blog - Generelle IT & Deployment Themen, DSM Themen und DSM Automatisierung via PowerShell
Reply With Quote
  #7  
Old April 6th, 2017, 13:54
gl-hl gl-hl is offline
Benutzer
 
Join Date: 10-29-12
Posts: 56
Default

Hallo zusammen,

wir haben uns bei diesen Modellen jetzt damit beholfen, einfach die BIOS settings abzuändern. Wichtig sind für uns UEFI + aktiviertem SecureBoot.

Schlussendlich musste ich den SATA Operation Mode von RAIDon auf AHCI umstellen.
Das ist nun mal jetzt so.

Beste Grüße
GL-HL

PS:
https://www.dell.com/support/article...drives?lang=EN
Reply With Quote
Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

vB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump

   

All times are GMT +1. The time now is 01:58.

Powered by vBulletin Version 3.6.7
Copyright ©2000 - 2017, Jelsoft Enterprises Ltd.