Go Back   Desktop & Server Management (DSM) Forum > GERMAN > enteo Release 5.x > Sonstiges
Register FAQ Members List Calendar Search Today's Posts Mark Forums Read

 
 
Thread Tools Search this Thread Display Modes
  #11  
Old April 17th, 2009, 08:30
Klaus Salger's Avatar
Klaus Salger Klaus Salger is offline
Erfahrener Benutzer
 
Join Date: 11-16-06
Location: Kissing b. München
Posts: 782
Default

Hallo Takis,

schön, das mit der Anmeldung habe ich verstanden. Erstaunlich ist jetzt nur, dass beim Zugriff auf den Management Point der Proxy verwendet werden soll. Stehen Client und Management nicht beide im Intranet? Normalerweise werden Ausnahmen konfiguriert um den Zugriff auf Intranet Server ohne Proxy zu machen. Ist das bei euch nicht der Fall?

Zu deinen Fragen:
Es gibt in NetInstall 5.8 die Möglichkeit auf NI-Datenbank-Ebene zu entscheiden, ob die Datenbank mit Assign & Delegate verwaltet werden soll oder nicht. Wenn die Datenbank A&D-managed ist, dann braucht man zwingend ein funktionierendes A&D incl. IIS und damit http.
Parallel kann es auch noch nicht A&D gemanagete NI-Datenbanken geben. Die funktionieren dann auch ohne A&D, IIS, http.

Im IIS müssen Berechtigungen im Regelfall nicht angepasst werden. Die werden bei der Installation des Management Points automatisch gesetzt. Ob ein Paket installiert werden darf oder nicht wird nicht wie im klassischen NetInstall per Berechtigungen auf das Paket gesteuert, sondern durch Zuweisung des Pakets zu Computer- oder Benutzergruppen. Die Information welche Pakete installiert werden können wird durch den NI Client über ein XML-File vom Management Point geholt. Und an der Stelle hakt’s bei dir offenbar – der Management Point kann nicht kontaktiert werden, Informationen zu dem Client incl. der zugewiesenen Pakete können nicht geladen werden.

Zum Testen wäre es günstig, wenn man die Proxy-Konfiguration bei einem Testclient ändern könnte. Dabei ist zu beachten, dass der NetInstall Client für den Zugriff auf den Management Point im Regelfall Winhttp verwendet, d.h. diese Einstellungen können sich von denen im Browser unterscheiden. Die winhttp-Proxy Settings kannst du auf XP und W2k3 per proxycfg.exe anschauen oder ändern, bei Vista und W2k8 geht das per netsh.

Viel Erfolg
Klaus
__________________
Klaus Salger | IT Consultant
www.axoquent.de/blog
  #12  
Old April 17th, 2009, 11:08
Takis Takis is offline
Neuer Benutzer
 
Join Date: 07-21-08
Posts: 27
Default

Hallo Klaus,

Danke nochmasl für deine ausführliche Informationen

zu deine Fragen:
Ja der Client und der Management Pint sind beide im Intranet.
Durch eine Globale GPO werden die Proxy-Einträge im IE eingetragen, mit aktivierten hacken für "Proxyserver für Lokale Adressen umgehen".
Das hat immer funktioniert. Enteo konnte die Packete auf dem Client übertragen/installieren.

Dann kam die Änderung mit der Authentifizierung im IE (deswegen die Vermuttung, sicher bin ich mir nicht). Normal sollte er auch nicht über den Proxy gehen damit er den Management Point ereichen kann, sehe ich auch ein.

Aber die Packete werden nicht installiert. OSD funtioniert problemlos...
bei der Zuweisung von Packete habe ich keine Reaktion

Habe auf dem XP-client den proxycfg eingegeben. Ergebnis:

WinHttpSettings:
Direkterzugriff (kein Proxyserver)

Wie ist das mit dem XML-File und Management Point?
Müssen da welche Dienste gestartet sein? Wie kann ich übeprüfen ob alles in dieser Einstellung korrekt ist??

Gruß
Takis
  #13  
Old April 17th, 2009, 12:01
Takis Takis is offline
Neuer Benutzer
 
Join Date: 07-21-08
Posts: 27
Default

Hallo Klaus,

kannst Du mit bezüglich dieser Fehlermeldung (vom Client) was sagen???:

12:11:37 1 ExRSend: Negotiating with server (Try #1) ...
12:11:37 0 OutboxAgent: SendRequest
12:11:37 0 OutboxAgent: Send a request - the global value of the Filepointer position is not set
12:11:37 0 OutboxAgent: Sending XML data...
12:11:37 1 OutboxAgent: Sending file to MgntPoint URL: http://s03maxx:8080/NIISAPI.dll
12:11:37 0 OutboxAgent: Http XML Handlertag: ExRep, Authentication: ANONYMOUS
12:11:37 0 OutboxAgent: please wait - connection timeout: max. 30 seconds ...
12:11:37 1 niHttp: Using WinHTTP.dll to send data
12:11:37 0 niHttp: WinHTTP: Send request
12:11:37 2 niHttp: HTTP Server returned an error, please check the server configuration: access denied
12:11:37 2 niHttp: Failed to receive answer: Unzulässige Funktion.

12:11:37 1 OutboxAgent: Receiving response...
12:11:37 2 OutboxAgent: Failed to send XML file: Failed to receive answer: Unzulässige Funktion.

12:11:37 2 ExRSend: Handshake with server failed. Try in 5 seconds again...
12:11:42 1 ExRSend: Negotiating with server (Try #2) ...
12:11:42 0 OutboxAgent: SendRequest
12:11:42 0 OutboxAgent: Send a request - the global value of the Filepointer position is not set
12:11:42 0 OutboxAgent: Sending XML data...
12:11:42 1 OutboxAgent: Sending file to MgntPoint URL: http://s03maxxx:8080/NIISAPI.dll
12:11:42 0 OutboxAgent: Http XML Handlertag: ExRep, Authentication: ANONYMOUS
12:11:42 0 OutboxAgent: please wait - connection timeout: max. 30 seconds ...
12:11:42 1 niHttp: Using WinHTTP.dll to send data
12:11:42 0 niHttp: WinHTTP: Send request
12:11:42 2 niHttp: HTTP Server returned an error, please check the server configuration: access denied
12:11:42 2 niHttp: Failed to receive answer: Unzulässige Funktion.

Wobei der S03MAxxx unsere Enteo-DB Server (Management Point) ist und dort auch der IIS aktiviert ist


Gruß
Takis
  #14  
Old April 17th, 2009, 13:03
Takis Takis is offline
Neuer Benutzer
 
Join Date: 07-21-08
Posts: 27
Default

Hallo Klaus,

habe den Fehler gefunden.

Auf dem IIS unter Management Point war unter Athentifizierung und Zugriffsteuerung der Anonymous Zugriff nicht aktiviert (jemand hat da herumgespielt)

Nach dem ich den hacken aktiviert habe läuft alles bzw. die installation der Packete werden durchgeführt


Nochmals DANKE für deine ausführlichen Informationen

Gruß
Takis
 


Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

vB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump

   

All times are GMT +1. The time now is 21:52.

Powered by vBulletin Version 3.6.7
Copyright ©2000 - 2017, Jelsoft Enterprises Ltd.