Go Back   Desktop & Server Management (DSM) Forum > GERMAN > DSM 7 > DSM 7 Imaging
Register FAQ Members List Calendar Search Today's Posts Mark Forums Read

Reply
 
Thread Tools Search this Thread Display Modes
  #1  
Old January 31st, 2012, 15:16
frank.reutter frank.reutter is offline
Neuer Benutzer
 
Join Date: 03-16-11
Posts: 2
Default shutdown statt reboot

Hi Zusammen,
wie erreiche ich, ohne aufwändige Anpassung meines PE 3.1, dass bei einer Pre-OS Action anschließend ein shutdown (kein Reboot!!!) gemacht wird? Die shutdown.exe ist in dieser PE-Version nicht mehr vorhanden.

Ich habe es mit folgendem Script am Ende versucht:

:: Done.
REM exit /B 0
set errorlevel=0
Wpeutil shutdown


Problem ist, dass trotzdem die Policy auf gelb stehen bleibt und jedes mal neu installiert wird.
Reply With Quote
  #2  
Old January 31st, 2012, 15:30
Mel Mel is offline
Erfahrener Benutzer
 
Join Date: 09-15-09
Posts: 1,921
Default

wenn du den rechner im script runterfährst, dann hat der client keine gelegenheit mehr seine ergebnisse an den proxy zu melden -> policyinstance bleibt gelb

lösung: den shutdown verzögern

zusätzliche cmd datei mit ins paket packen, die erstmal 20 mal die 127.0.0.1 anpingt bevor sie den shutdown macht.
diese cmd am ende des scriptes mit "start" starten.
damit hat der client 20 sekunden für seine erfolgsmeldung, was i.d.R. reichen sollte.
Reply With Quote
  #3  
Old February 6th, 2012, 13:38
frank.reutter frank.reutter is offline
Neuer Benutzer
 
Join Date: 03-16-11
Posts: 2
Default

super, vielen Dank funktioniert einwandfrei!
Reply With Quote
Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

vB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump

   

All times are GMT +1. The time now is 15:10.

Powered by vBulletin Version 3.6.7
Copyright ©2000 - 2017, Jelsoft Enterprises Ltd.