Go Back   Desktop & Server Management (DSM) Forum > GERMAN > enteo Release 5.x > enteo Inventory
Register FAQ Members List Calendar Search Today's Posts Mark Forums Read

Closed Thread
 
Thread Tools Search this Thread Display Modes
  #1  
Old February 25th, 2011, 08:44
Gni Gni is offline
Neuer Benutzer
 
Join Date: 12-20-10
Posts: 17
Default Inv 3.20 - [SOLVED] Daten werden nicht gesendet

Guten Tag

Seit geraumer Zeit haben wir ein Problem mit dem Netinvenory 3.2 unserer 5.8 Umgebung. Und zwar werden die XML-Files vom Client nicht in die Inbox des Servers gesendet. Dieses Problem wurde schon einmal von jemandem im Forum gepostet, doch dort wird die Installation des neusten Cumu-Patches vorgeschlagen und der ist bei uns schon installiert (Patch 1553).

Die XML-Files auf dem Server werden erstellt, können dann aber nicht gesendet werden. Folgender Fehler taucht im LOG-File auf:

Code:
09:01:01 2  Starting process of C:\Programme\NetInst\TallySystems\Colw32.exe. Please wait.
09:01:19 2 SI: Rewriting SI client state data...
09:01:19 2 SI: Rewriting SI client state data...
09:01:19 2 Creating TSC delta file: 
	fs1: C:\Programme\NetInst\NetInventory\Client\{6782AC2E-C25B-427E-AD89-016914799876}\Inv.{6782AC2E-C25B-427E-AD89-016914799876}_TSCFS_2.xml 
	fs2: C:\Programme\NetInst\NetInventory\Client\{6782AC2E-C25B-427E-AD89-016914799876}\Inv.{6782AC2E-C25B-427E-AD89-016914799876}_TSC.xml 
	df: C:\Programme\NetInst\NetInventory\Client\{6782AC2E-C25B-427E-AD89-016914799876}\Inv.{6782AC2E-C25B-427E-AD89-016914799876}_TSCD_3.xml
09:01:20 2  SI: Determining current Management Point by MgntApp 'NetInventory30' ...
09:01:20 2  SI: Current Management Point with 'NetInventory30': Management Point.WRH [204147]
09:01:20 2  SI: Rewriting SI client state data...
09:01:22 E  Warning (Module:Main, Severity:0x02): Instances not found for the class NI_Inv20 so it will be skipped
09:01:22 E  Warning (Module:Main, Severity:0x02): Instances not found for the class NI_Inv30 so it will be skipped
09:01:22 E  Warning (Module:Main, Severity:0x02): Instances not found for the class Win32_1394Controller so it will be skipped
09:01:24 E  Warning (Module:Main, Severity:0x02): Instances not found for the class Win32_SCSIController so it will be skipped
09:01:24 2 SI: Rewriting SI client state data...
09:01:24 2 SI: Rewriting SI client state data...
09:01:24 2 Creating delta file: 
fs1: C:\Programme\NetInst\NetInventory\Client\{6782AC2E-C25B-427E-AD89-016914799876}\Inv.{6782AC2E-C25B-427E-AD89-016914799876}_FS_2.xml 
fs2: C:\Programme\NetInst\NetInventory\Client\{6782AC2E-C25B-427E-AD89-016914799876}\Inv.{6782AC2E-C25B-427E-AD89-016914799876}_FS_4.xml 
daf: C:\Programme\NetInst\NetInventory\Client\{6782AC2E-C25B-427E-AD89-016914799876}\Inv.{6782AC2E-C25B-427E-AD89-016914799876}_5.xml 
ddf: C:\Programme\NetInst\NetInventory\Client\{6782AC2E-C25B-427E-AD89-016914799876}\Inv.{6782AC2E-C25B-427E-AD89-016914799876}_4.xml
09:01:25 2 No Network discovery was performed!
09:01:25 2  Sending inventory client ...
09:01:25 2  OutboxAgent: send XML failed, errormessage from IIS: no handler for nodename: NetInv
09:01:25 E  Warning (Module:OutboxAgent, Severity:0x03): ] 
09:01:25 2  Failed to send request09:01:25 2 Uninitializing NIRT (Quality Assurance and Support)
Manuell kann ich die Files in die Inbox des Servers einfügen, worauf die Daten im Inventory abgerufen werden können. Wegen dem Log vermute ich, dass es etwas mit dem IIS zu tun hat. Zudem wird der Inbox-Service als nicht gestartet angezeigt und lässt sich auch nicht starten.
Weiter bin ich leider noch nicht gekommen. Deshalb wollte ich hier mal nachfragen, ob jemand dieses Problem auch schon hatte oder sonstige Lösungsideen hat.

Vielen Dank und freundliche Grüsse
Micha
  #2  
Old February 25th, 2011, 09:21
thertkorn thertkorn is offline
Erfahrener Benutzer
 
Join Date: 10-10-06
Posts: 384
Default

das liegt am IIS auf dem Server wo die Inbox läuft.
Notfalls installiere Netinventory nochmals neu.
Managementpoint und dann auf deinstallieren
Reboot
dann nochmal neu installieren.

Ebenfalls mal die Rechte auf dem IIS kontrollieren.

Achtung: beim letzten build NI 5.85 ist ein Bug dabei wenn man den Managementpoint installieren will. Setup Sagt es sei kein Windows Server vorhanden.
Es gibt ne neue dll beim Support.

Setzt du wirklich noch 5.8 ein?
Würde dir empfehlen mal auf eine neuere Version umzusteigen zumindest 5.85 / 5.86 oder dann v6/v7
  #3  
Old February 25th, 2011, 10:17
Gni Gni is offline
Neuer Benutzer
 
Join Date: 12-20-10
Posts: 17
Default

Wir sind gerade dabei auf 6.2 umzusteigen und damit produktiv zu gehen. Doch teilweise wäre das alte Inventory noch nützlich.

Netinventory habe ich schon neu installiert, leider ohne Erfolg.

Welche Rechte gibt es dann beim IIS speziell zu beachten? Die lokalen User haben Lese -und Ausführungsrechte auf dem Verzeichnis.

Vielen Dank für Deine Hilfe!
  #4  
Old March 1st, 2011, 10:01
Gni Gni is offline
Neuer Benutzer
 
Join Date: 12-20-10
Posts: 17
Default

Nachdem ich das Inventory-Addon deinstalliert hatte, löschte ich die Inventory-Website auf dem IIS. Nach der Installation wurde dann bei der Inventory-Konsole ein bekannter Parser-Fehler angezeigt, welchen ich beheben konnte. (http://forum.enteo.com/showthread.php?t=2758)

Leider blieb auch dieser Versuch ohne Erfolg. Auch die Rechte sollten gemäss Dokumentation richtig vergeben sein.

Sobald ich dann den Status der Komponenten im Netinstall Manager/Management Point aktualisieren will, erscheint eine Fehlermeldung, dass ein oder mehrere Dienste nicht richtig gestartet werden konnte. Es wird mir dann ein Log angezeigt (IBAgnt.txt) welches schon 3 Monate alt ist. Leider finde ich darin keine Hinweise auf einen Fehler oder warum der Inbox-Dienst sich nicht starten lässt.

Ich hoffe der einte oder andere Hinweis ist nutzbar.

Grüsse
Micha
  #5  
Old March 2nd, 2011, 08:59
Gni Gni is offline
Neuer Benutzer
 
Join Date: 12-20-10
Posts: 17
Default

Nachdem ich mit dem enteo-Support Kontakt aufgenommen habe, konnte das Problem gelöst werden. Und zwar funkte noch etwas von der A&D-Addon dazwischen, welches wir nicht verwenden.

Es musste der Registry-Schlüssel HKEY_LOCAL_MACHINE\SOFTWARE\update4u\NiIsapi\DTM gelöscht werden.
Closed Thread


Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

vB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump

   

All times are GMT +1. The time now is 07:59.

Powered by vBulletin Version 3.6.7
Copyright ©2000 - 2017, Jelsoft Enterprises Ltd.